Facebook Pixel Code

Technical RequirementsTechnical Requirements for Online Learning

 The following technical requirements are designed to help you prepare for a positive Online Learning. Moodlerooms and Canvas are the Learning Management Systems (LMS) used by Mt. San Antonio College. They are used by both traditional courses, and distance learning courses. 

Hardware Requirements Software Requirements

You will need a desktop or a notebook computer to get the most out of the learning management systems. While smartphones and tablets are technically compatible with using either of the LMS programs, they are not compatible with all functions, and thus aren't fully supported.

You may use your smartphone or tablet to view your classroom and access information, but tools such as forums, or submitting assignments may not be available via mobile devices.

Operating System:

  • Microsoft Windows XP or newer (Windows 7 recommended)
  • Mac OSX 10.5 or newer
  • Google Chrome OS (used in Chromebooks)

Processor: 1.5Ghz or faster

Memory: 1Gb of RAM or more

Storage: 20Gb HDD or more

Soundcard and Speakers: Recommended

Microphone: Optional but recommended. Your professor might encourage the use of a microphone for classroom collaboration

Printer: Graphics-capable (inkjet or laser printer)

Software: Microsoft Office suite or access to Google Docs

Internet Browser: (be sure to always have the most updated version)

Browser Plug-ins: The following plug-ins may be required by your professor in order to access online course materials.

  • Adobe PDF Reader - for viewing Portable Document Files (PDF)
  • Quicktime Player - for viewing movies
  • Flash Player - for viewing animations and online videos

*Please note that we recommend disabling your pop-up blocker, or white-listing mtsac.mrooms.net (Moodlerooms) or mtsac.instructure.com (Canvas) so that it doesn't negatively affect your experience. The learning management systems can display pop-ups related to private messages or other tools based on your notifications settings. The learning management systems will never display pop-up advertisements.

Java Runtime Environment: You will need a recent version of the Sun Microsystems Java Runtime Environment (JRE) installed for certain Moodlerooms tools to function properly. To get the latest version JRE  you can visit the Sun website.


lightbulbInstructor-specific Requirements:

Your instructor may alter or add to these technical requirements. Please read your course syllabus carefully!


Back to the DL Student home page